Monthly Archives: January 2018

Spectre and Meltdown Vulnerabilities for IT Professionals

Spectre and Meltdown Vulnerabilities for IT Professionals On January 3, 2018 information about three vulnerabilities in computer processors was made public (https://meltdownattack.com/ ). Collectively, these have been dubbed “Meltdown” (CVE-2017-5754) and ”Spectre” (CVE-2017-5753 and CVE-2017-5715). Many vendors have had this information previous

Posted in Security Alert